[Switch Dell] Quelques commandes en vrac ..

 

Switch Dell quelques commandes en vrac ..
Article original Publié le : 16 décembre 2017

Mise a jour le : 28 novembre 2018

 

 


Configurer switch Dell en ssh
Se connecter sur le switch en CLI (telnet ou série)Pour activer le SSH, entrer les commandes suivantes

$ enable
# configure
(config)# crypto key generate rsa
(config)# crypto key generate dsa
(config)# ip ssh server

 

Se connecter en SSH pour vérifier que cela fonctionne puis désactiver telnet avec la commande

(config)# no ip telnet server

Configurer switch Dell en HTTPS

/!\ Peux varier selon les modèles

Méthode 1, entrer les commandes suivantes

(config)# crypto certificate 1 generate
(config-crypto-cert)# key-generate <512-2048>
(config-crypto-cert)# exit
(config)# ip http secure-certificate 1
(config)# ip http secure-server

 

Méthode 2, entrer les commandes suivantes

(config)# crypto certificate 1 generate key
(config)# ip https certificate 1
(config)# ip http secure-server

 

Il est possible de générer et de stocker deux certificats.
Pour générer la deuxième clé, remplacez le chiffre 1 par le chiffre 2.
Pour activer la deuxième clé, utilisez la commande (config)# ip http secure-certificate 2

 

Assurez vous que le protocole HTTPS fonctionne, puis désactiver HTTP avec la commande

(config)# no ip http server

Faire une sauvegarde

# copy running-config startup-config

Commande do

/!\ la commande do s’utilise quand on est déjà en mode conf et que l’on veux utiliser une commande non conf.

Dans l’exemple

(config)# show interfaces status | include mot_a_recherche

ou

(config)# do show running interfaces gi 1/0/9

Attribuer une adresse  IP depuis le port console (série ou rj)

Depuis un client putty, hyper terminal, minicom

Baud: 9600
Data bits: 8
Stop bits: 1
Parity: none
Flow control: none

/!\ Ajouter VT100+ pour Putty dans Terminal/Keyboard

 

Puis taper les commandes

$ configure
(config)# interface vlan 1
(config-if)# ip address 192.168.x.x 255.255.255.0

Faire une sauvegarde

# copy running-config startup-config

Pour lister la configuration d’un switch

# show running-config

Pour vérifier le status d’un port

# show interfaces gigabitEthernet 1/0/13 status
Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/0/13                     notconnect   1            auto   auto 10/100/1000BaseTX
----------------------------------------------------------------------------------------

Pour faire une recherche sur un mot précis (exemple dans la description d’un port)

# show interfaces status | include mot_a_recherche
Gi1/0/9   mot_a_recherche     connected    112        a-full a-1000 10/100/1000BaseTX
Gi1/0/10  mot_a_recherche     connected    160        a-full a-1000 10/100/1000BaseTX
Gi2/0/11  mot_a_recherche     connected    238        a-full a-1000 10/100/1000BaseTX
Gi2/0/14  mot_a_recherche     connected    1          a-full a-1000 10/100/1000BaseTX
----------------------------------------------------------------------------------------

Avoir la configuration d’un port précis

# show running-config int Gi 1/0/9
Building configuration...
Current configuration : 174 bytes
!
interface GigabitEthernet1/0/9
 description PORTXX:ETHX
 switchport access vlan 112
 switchport mode access
 spanning-tree portfast
 spanning-tree bpduguard enable
end

Se connecter puis configurer un port

Une fois connecté au switch passer en édition

$ enable

Puis passer en mode configuration

#conf t

Se connecter a l’interface 13 du switch 1

(config)# interface gigabitEthernet 1/0/13

On passe en (config-if), cela va permettre de configurer le port, par exemple y mettre une description, Son vlan et le spanning tree

(config-if)# description ma_machine:ethx
(config-if)# switchport acces vlan 100
(config-if)# spanning-tree portfast edge
(config-if)# spanning-tree bpduguard enable

 

Pour sortir utiliser la commande exit

/!\ ne pas oublier de faire une sauvegarde /!\

# copy running-config startup-config

Configurer un mot de passe et un niveau de privilège

Les niveaux de privilège
level 1 = pas de privilège, équivalent a la lecture seule
level 15 = Équivalent au privilège admin

$ enable
# configure
(config)# username admin password taper_le_mot_de_passe level 15

Faire une sauvegarde

console> copy running-config startup-config

Monitorer connexion depuis un switch

Passer en mode enabled et lancer la commande

# term mon

Faire un shutdown d’une interface réseau et la remonter.

# ip li set eth0 down
# ip li set eth0 up

Différents logs s’afficheront comme

Switch1 : Interface Ethernet1/26 is down in mode trunk
...
...
...
Switch1 : Interface Ethernet1/26 is up in mode trunk

 

Couper le monitor

# term no mon

Lister les ports channel

La conf est faite sur 2 switchs en stack, les ports sont donc redondés, une interface sur le port channel 2 est down, non branché.

# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

        A - formed by Auto LAG


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/0/01(P) Gi2/0/01(P) 
2      Po2(SU)         LACP      Gi1/0/02(P) Gi2/0/02(D) 

Configuration des ports channel ci dessus

# show running-config int Gi1/0/01
Building configuration...

Current configuration : 176 bytes
!
interface GigabitEthernet1/0/01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode active
end
# show running-config int Gi2/0/01
Building configuration...

Current configuration : 176 bytes
!
interface GigabitEthernet2/0/01
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode active
end

Avoir la mac adress d’un port

# show mac address-table interface gi 1/0/35

Exemple de configuration d’un port en trunk

# show running-config int Gi1/0/05
Building configuration...

Current configuration : 289 bytes
!
interface GigabitEthernet1/0/05
 description ma_machine:ethx
 switchport trunk allowed vlan 112-114,117
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast edge trunk
 spanning-tree bpduguard enable
 channel-protocol lacp
 channel-group 9 mode passive
end
# show running-config int Gi2/0/05
Building configuration...

Current configuration : 280 bytes
!
interface GigabitEthernet2/0/05
 description ma_machine:ethx
 switchport trunk allowed vlan 112-114,117
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast edge trunk
 spanning-tree bpduguard enable
 channel-protocol lacp
 channel-group 9 mode passive
end

Vlan

Le mode Acces ne peux avoir qu’un seul vlan

Le mode Trunk peux en recevoir plusieurs separé par une virgule


Pour lister tous les vlans

#show vlan
...
130  Baxx         active    Gi1/0/15
131  Frxx         active    Gi1/0/16, Gi1/0/22
132  Trxx         active    
225  Adxx         active    Gi1/0/39
226  Vlxx         active    
227  Daxx         active    Gi1/0/19
228  Doxx         active    Gi1/0/38, Gi1/0/41
..

Pour ajouter un vlan a un port channel

(config)# interface port-channel 1
(config-if-ch1)# switchport trunk allowed vlan add 555

Créer un vlan sur un switch
(config)#vlan numéro_du_vlan
(config-if)#name donner_un_nom

Puis exit


Switch erreur err-disabled

Sur le socle

# ip a | grep eno2 && ip a | grep eno3
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000
4: eno3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master ovs-system state DOWN group default qlen 1000

 

Sur le switch

# sh int gi1/0/42 status
Port Name Status Vlan Duplex Speed Type
Gi1/0/42 description_machine err-disabled 1 auto auto 10/100/1000BaseTX
# sh int gi2/0/42 status
Port Name Status Vlan Duplex Speed Type
Gi2/0/42 description_machine connected trunk a-full a-1000 10/100/1000BaseTX

 

Vérification de la conf des ports

#sh run int gi2/0/42    
Building configuration...

Current configuration : 253 bytes
!
interface GigabitEthernet2/0/42
 description description_machine:eth2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
 channel-protocol lacp
 channel-group 41 mode passive
end

#sh run int gi1/0/42
Building configuration...

Current configuration : 253 bytes
!
interface GigabitEthernet1/0/42
 description description_machine:eth1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
 channel-protocol lacp
 channel-group 41 mode passive
end

 

Verifier les interfaces

# sh int Gi1/0/42
GigabitEthernet1/0/42 is down, line protocol is down (err-disabled) 

...
# sh int Gi2/0/42
GigabitEthernet2/0/42 is up, line protocol is up (connected)

...

Comme c’est un port channel, on shut l’interface qui pose probleme et on la relane pour voir si elle remonte

(config)# int gi1/0/42
(config-if)# shut
(config-if)#no shut

Puis verifier l’etat du port, non resolue, etat suspendue

# sh int gi1/0/42
GigabitEthernet1/0/42 is up, line protocol is down (suspended)

Enfin on verifie le port channel, on remarque que les interfaces ne vont pas a la meme vitesse

#show etherchannel 41 detail
Group state = L2 
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0
		Ports in the group:
		-------------------
Port: Gi1/0/42
------------

Port state    = Up Cnt-bndl Suspend Not-in-Bndl 
Channel group = 41          Mode = Passive         Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po41
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/42  SP      susp      32768         0x29      0x29    0x12B       0x4   

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi1/0/42  SP      65535     d4be.d9fb.9eb3   3s    0x0    0x1    0x1     0x34  

Age of the port in the current state: 0d:00h:01m:17s

Probable reason: speed of Gi1/0/42 is 100M, Gi2/0/42 is 1000M
Port: Gi2/0/42

Revenir sur le socle et reset le port reseau avec la commande

# mii-tool -R eno3

On reverifie les interfaces reseaux sur le socle

# ip a | grep eno2 && ip a | grep eno3
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000
4: eno3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000

Sur le switch

# sh int Gi1/0/42
GigabitEthernet1/0/42 is up, line protocol is up (connected)

Sur le port channel

# sh int gi1/0/42 status
Port Name Status Vlan Duplex Speed Type
Gi1/0/42 description_machine connected trunk a-full a-1000 10/100/1000BaseTX
# sh int gi2/0/42 status
Port Name Status Vlan Duplex Speed Type
Gi2/0/42 description_machine connected trunk a-full a-1000 10/100/1000BaseTX

Modification d’un port channel

Vérifier la configuration du port channel

# show running-config interface port-channel 10
Building configuration...

Current configuration : 163 bytes
!
interface Port-channel10
 description ma_machine:bond0
 switchport trunk allowed vlan 220-222
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

Puis passer en mode conf pour modifier et plage de vlan et en rajouter un.

(config)#conf t
(config)#interface port-channel 10
(config-if)# switchport trunk allowed vlan 220-225
(config-if)# switchport trunk allowed add vlan 200

re-vérifier la conf

(config-if)#do show running-config interface port-channel 10
Building configuration...

Current configuration : 163 bytes
!
interface Port-channel10
 description ma_machine1:bond0
 switchport trunk allowed vlan 200,220-225
 switchport trunk encapsulation dot1q
 switchport mode trunk
end























 

 

No votes yet.
Please wait...

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.